st/PKGBUILD
2023-08-28 11:31:16 +02:00

32 lines
679 B
Bash

# Maintainer: speedie <speedie.alt@gmail.com>
pkgname=st-spde
pkgver=1.3
pkgrel=1
pkgdesc="speedie's fork of st with .Xresources, pywal, alpha, and more."
url="https://git.speedie.site/speedie/st"
arch=(i686 x86_64)
license=(MIT)
depends=(sh libxft libx11 gd harfbuzz)
makedepends=()
provides=($pkgname)
conflicts=($pkgname)
source=(
"https://ls.speedie.site/releases/$pkgname/$pkgname-$pkgver.tar.gz"
)
md5sums=('SKIP')
build(){
cd $pkgname-$pkgver
make \
X11INC=/usr/include/X11 \
X11LIB=/usr/lib/X11
}
package() {
cd "$pkgname-$pkgver"
make PREFIX=/usr DESTDIR="$pkgdir" install
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}